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MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser
General Public License for more details. You should have received a copy of the GNU
Lesser General Public License along with this library; if not, write to the Free Software
Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA Permission is
hereby granted to use or copy this program under the terms of the GNU LGPL, provided
that the Copyright, this License, and the Availability of the original version is retained on
all copies.User documentation of any code that uses this code or any modified version of
this code must cite the Copyright, this License, the Availability note, and "Used by
permission." Permission to modify the code and to distribute modified code is granted,
provided the Copyright, this License, and the Availability note are retained, and a notice
that the code was modified is included. AMD Availability:
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as published by the Free Software Foundation; either version 2.1 of the License, or (at
your option) any later version. This library is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General Public License for
more details. You should have received a copy of the GNU Lesser General Public License
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Qt Version 4.6.3, Copyright (c) 2010 by Nokia Corporation. All Rights Reserved. Qt
License: Your use or distribution of Qt or any modified version of Qt implies that you agree
to this License. This library is free software; you can redistribute it and/or modify it under
the

terms of the GNU Lesser General Public License as published by the Free Software
Foundation; either version 2.1 of the License, or (at your option) any later version. This
library is distributed in the hope that it will be useful,

but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General Public License for
more details. You should have received a copy of the GNU Lesser General Public License
along with this library; if not, write to the Free Software Foundation, Inc., 51 Franklin St,
Fifth Floor, Boston, MA 02110-1301 USA Permission is hereby granted to use or copy this
program under the terms of the GNU LGPL, provided that the Copyright, this License, and
the Availability of the original version is retained on all copies.User

documentation of any code that uses this code or any modified version of this code must
cite the Copyright, this License, the Availability note, and "Used by permission."
Permission to modify the code and to distribute modified code is granted, provided the
Copyright, this License, and the Availability note are retained, and a notice that the code
was modified is included. Qt Availability: http://www.gtsoftware.com/downloads Patches
Applied to Qt can be found in the installation at:
$HPEESOF_DIR/prod/licenses/thirdparty/qt/patches. You may also contact Brian
Buchanan at Agilent Inc. at brian_buchanan@agilent.com for more information.

The HISIM_HV source code, and all copyrights, trade secrets or other intellectual property
rights in and to the source code, is owned by Hiroshima University and/or STARC.

Errata The ADS product may contain references to "HP" or "HPEESOF" such as in file
names and directory names. The business entity formerly known as "HP EEsof" is now part
of Agilent Technologies and is known as "Agilent EEsof". To avoid broken functionality and
to maintain backward compatibility for our customers, we did not change all the names
and labels that contain "HP" or "HPEESOF" references.
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Warranty The material contained in this document is provided "as is", and is subject to
being changed, without notice, in future editions. Further, to the maximum extent
permitted by applicable law, Agilent disclaims all warranties, either express or implied,
with regard to this documentation and any information contained herein, including but not
limited to the implied warranties of merchantability and fitness for a particular purpose.
Agilent shall not be liable for errors or for incidental or consequential damages in
connection with the furnishing, use, or performance of this document or of any
information contained herein. Should Agilent and the user have a separate written
agreement with warranty terms covering the material in this document that conflict with
these terms, the warranty terms in the separate agreement shall control.

Technology Licenses The hardware and/or software described in this document are
furnished under a license and may be used or copied only in accordance with the terms of
such license. Portions of this product include the SystemC software licensed under Open
Source terms, which are available for download at http://systemc.org/ . This software is
redistributed by Agilent. The Contributors of the SystemC software provide this software
"as is" and offer no warranty of any kind, express or implied, including without limitation
warranties or conditions or title and non-infringement, and implied warranties or
conditions merchantability and fitness for a particular purpose. Contributors shall not be
liable for any damages of any kind including without limitation direct, indirect, special,
incidental and consequential damages, such as lost profits. Any provisions that differ from
this disclaimer are offered by Agilent only.

Restricted Rights Legend U.S. Government Restricted Rights. Software and technical
data rights granted to the federal government include only those rights customarily
provided to end user customers. Agilent provides this customary commercial license in
Software and technical data pursuant to FAR 12.211 (Technical Data) and 12.212
(Computer Software) and, for the Department of Defense, DFARS 252.227-7015
(Technical Data - Commercial Items) and DFARS 227.7202-3 (Rights in Commercial
Computer Software or Computer Software Documentation).
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Introducing the Filter DesignGuide

The Filter DesignGuide documentation provides an introduction to the Filter DesignGuide
tool. The complexity of the Advanced Design System (ADS) is made easily accessible
through the automated capability. A first-time or casual ADS user can begin using the
capability of ADS quickly, while experienced ADS users can perform tasks faster than ever
before. The Step-by-Step Example describes how a doubly terminated lowpass Chebyshev
filter can be designed and verified, and a layout generated, in a few minutes.

The Filter DesignGuide provides SmartComponents and automated-assistants for the
design and simulation. All SmartComponents can be modified. You simply select a
SmartComponent and, with little effort, redesign or verify their performance. The "Using
SmartComponents" section answers many common questions relating to DesignGuide use
and the "SmartComponent Reference" describes each SmartComponent in detail. The
section "Automated Design and Analysis" introduces Automated Assistants.

Step-by-Step Example
The step-by-step example takes you through the design, analysis and sensitivity
simulation of a doubly terminated lowpass Chebyshev filter component. After completing
this example, you should have a basic understanding of the DesignGuide and be ready to
begin using the tool.
Follow these steps to begin:

o Setting Up the Design Environment

+ Designing and Analyzing a Network

© Note
You should already be familiar with the basic features of Advanced Design System. For help with
ADS basic features, refer to the Schematic Capture and Layout (usrguide) documentation.

Setting Up the Design Environment

Before you can use the Filter DesignGuide, you must set up the design environment by
using these steps:

e Setting DesignGuide Preferences

Opening a Workspace,

Opening a Schematic Window,

Opening the Filter DesignGuide,

Displaying the SmartComponent Palette.
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© Note
Before beginning, you must have installed the DesignGuide with appropriate licensing codewords.

Setting DesignGuide Preferences

All DesignGuides can be accessed through either cascading menus or dialog boxes. You
can configure your preferred method in the ADS Main window or from the Schematic
window.

To configure access through menus or dialog boxes:

1. From the Main or Schematic window, choose DesignGuide > Preferences.
2. In the DesignGuide Menu Style group box, choose either Use a selection dialog
box or Use cascade menus.

2 DesignGuide Preferences @

PLEASE MOTE: &ny changes made to these options require
restarting A0S to take effect,

Show Designizuide Menu

The Designizuide Preferences menu will still be available
in the Main window if yaou hide the DesignGuide menu
in the Schematic and Lavout windows,

Designiauide Menu Style
(%) Use a selection dialog box
() Use cascade menus

WYARMING: Due to Windows resource issues, using
cascade menus on a PC may destabilize your swskem
when multiple windows are open.

3. Close and restart the program for your preference changes to take effect.

© Note
On PC systems, Windows resource issues might limit the use of cascading menus. When multiple
windows are open, your system could become destabilized. Thus the dialog box menu style might be
best for these situations.

The ADS Main window DesignGuide menu contains the following choices:

« DesignGuide Developer Studio > Start DesignGuide Studio is only available on
this menu if you have installed the DesignGuide Developer Studio to open the initial
Developer Studio dialog box.

« DesignGuide Developer Studio > Developer Studio Documentation is only
available on this menu if you have installed the DesignGuide Developer Studio to
open the DesignGuide Developer Studio documentation. Another way to access the
DesignGuide Developer Studio documentation is by selecting Help > Topics and

8
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Index > DesignGuides > DesignGuide Developer Studio (from any ADS
program window).

« Add DesignGuide opens a directory browser in which you can add a DesignGuide to
your installation. This is primarily intended for use with DesignGuides that are
custom-built through the Developer Studio.

« List/Remove DesignGuide opens a list of your installed DesignGuides. Select any
that you would like to uninstall and choose the Remove button.

« Preferences opens a dialog box that enables you to:

o Disable the DesighGuide menu commands (all except Preferences) in the Main
window by unchecking this box. In the Schematic and Layout windows, the
complete DesignGuide menu and all of its commands are removed if this box is
unchecked.

o Select your preferred interface method (cascading menus vs. dialog boxes).

Opening a Workspace
The ADS design environment is set up within a Workspace.
To create a new Workspace:

1. From the ADS Main window, choose File > New Workspace or click Create a New
Workspace on the toolbar.

wiw B'aWBD>M=%

L Create a new workspace

2. In the dialog, define the location of the Workspace and assign a Workspace name.
For details on creating or opening an existing Workspace, refer to Using Workspace
(adstour).

Opening a Schematic Window
A new schematic design is needed to contain the lowpass component for this example.
To open a Schematic window:

1. From the ADS Main window, choose Window > New Schematic or click New
Schematic Window on the toolbar. A New Schematic window appears.

wiw =6 WBD>m=%

MNew Schematic window
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© Note
Depending on how your ADS preferences are set, a Schematic window can appear automatically
when you create or open a Workspace.

2. In the Schematic window, provide appropriate library and cell details, click OK to
create a design named Example.

Opening the Filter DesignGuide

The Filter DesignGuide is accessed from the Tools menu or the DesignGuide menu in
the Schematic window.

To open the Filter DesignGuide:

1. In the Schematic window, choose DesignGuide > Filter > Filter Control Window
to open the Control window.

Using the Control Window

All DesignGuide features are available from the Control window. The Control window
houses menus, a toolbar, and SmartComponent manipulation controls. The menus and
toolbar buttons perform the basic functions of design, delete, and display the
SmartComponent palette. Full features are available from each of the tab pages on the
window. The window can be placed anywhere on the screen. Explore each tab page by
clicking on the tab at the top of each page. Explore the window menus as well to
familiarize yourself with the basic DesignGuide capabilities.

The pull down lists at the top of the Control window are designed to help you navigate
multiple schematic windows and SmartComponents. You can use the Current Schematic
drop-down list box to select any of the currently opened schematic windows. This field is
updated any time the Filter Control window is selected from the Tools menu. From the
SmartComponent drop-down list box, you can select any of the SmartComponents on
the currently selected schematic window.

10
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Start Simulation

To close the Control window:

« Select File > Exit DesignGuide from the Control window menubar. (You can also

close the window by clicking the x at the top of the window.)
Continue the step-by-step example by Designing and Analyzing a Network.

Designing and Analyzing a Network

In this step-by-step example, you design and analyze a doubly terminated lowpass
Chebyshev filter component. A component can be designed easily by using the default
component parameter settings. Using the DesighGuide follows a normal design flow

procedure:

« Select a component needed for your design from the component palette (Displaying
the SmartComponent Palette) and placing the component in your design (Placing

Example Component in the Design).

» Provide specifications (Changing SmartComponent Parameters).

11
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e Design and analyze the component (Designing the SmartComponent) and Analyzing
Yield of the Network).

© Note
Before starting this section of the step-by-step example, confirm your setup (Setting Up the Design

Environment).

Displaying the SmartComponent Palette

The program contains a SmartComponent palette, Filter DG - All , that provides quick and
easy access to the SmartComponents. A blue accent in the upper-left corner of a palette
button indicates the component is a SmartComponent.

| Filter D - Al w
Palette A
oT oT
faa KV}
oT oT
(v KV}
=T =T . i
7 = Blue mark indicates a
-@- ’C_@_ SmartComponent
=T =T

You can display the SmartComponent palettes in one of these ways:
« By clicking Component Palette on the Control window toolbar.
e By choosing View > Component Palette - All from the Control window menu.
e By selecting the Filter DG - All palette from the Component Palette drop-down list
box in the Schematic window toolbar (directly above the palette).

Continue the example by selecting the Filter DG - All palette. The palette displays in the
Schematic window.

Placing Example Component in the Design
To place the SmartComponent in the design:

1. Click LCLowpassDT on the component palette to select the component.

12
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LCLowpassDt
Paletti ]
v V)
oT oT
Al Vi)
oT oT
AV Ve
T T
A Vi)
T T

2. Click within the schematic window to place the component.

e You can change the orientation of the SmartComponent before placement by
selecting from the Insert > Component > Component Orientation commands or
by selecting Rotate by -90 repeatedly from the schematic toolbar.

e The place component mode remains active until you choose End Command
from the Edit menu in schematic toolbar.

© Note
When a SmartComponent is placed initially, a temporary component is used to place and
specify the parameters for the SmartComponent. This component does not contain a
subnetwork design. After the DesignGuide has been used to design the SmartComponent, the
temporary component is replaced with a permanent component. The SmartComponent is
renamed to DA_ComponentName_DesignName and an autogenerated design is placed inside
the SmartComponent's subnetwork design file. Subsequently, if the SmartComponent
parameters are edited, the DesignGuide must be used again to update the subnetwork design
file.

Changing SmartComponent Parameters
Parameters can be changed directly from the Control window.
To edit the LCLowpassDT component parameters:

1. In the Control window, select the LCLowpassDT ** component from the
SmartComponent drop-down list. This ensures all changes are referenced to this
component.

2. Select the Filter Assistant tab. Change the response type by selecting the Response
Type drop-down menu box. Choose Chebyshev.

O Note
See "Placing and Editing SmartComponents" for details on changing parameters in the design

window or component dialog box.

Designing the SmartComponent

13



Advanced Design System 2011.01 - Filter DesignGuide
You can design and analyze the SmartComponent from the Control Window.

To start the simulation:

1. On the Filter Assistant tab, click Design to start a simulation and generate the design
for the SmartComponent.

Examining the SmartComponent Design

You can look at the details of the autogenerated design inside the SmartComponent's
subnetwork.

To examine the component's subnetwork:
1. Select the component LCLowpassDG.

2. Click Push Into Hierarchy on the schematic toolbar.
3. After examining the design, click Pop Out on the schematic toolbar to close the view.

&=

Push Into Hierarchy

L1
L=5 BE3I2T nH

|
HoSalial - < Siiian <

Pz

Hum=2

Mam=1

Pop Out £
"'r-nmtm..pf

To analyze (simulate) the network:

| F1

C=10 856374 oF

IHE——— ——

1. Select the Simulation Assistant tab on the Control window.
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Helps T Click Simulate
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"Create Template" creates a simulation template For manual SmartComponent sir

2. Confirm that Automatically Display Results is active.
3. Accept default frequency/display specifications. Click Simulate to start the analysis.
Part of the analysis results are shown below.
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Closing the Results Window
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e To close the display window, choose File > Close Window from the menu.

Analyzing Yield of the Network

After the design process, the component sensitivities of the network can be checked using
the Yield Assistant.

To find components to analyze:

1. Select the Yield Assistant tab on the Control window.

£ Filter DesignGuide

File  Tools  Wiew

of A X H

Current Schematic SmarkComponent
|Filterdg:u:ell_4:su:hematiu: * (Schemakic); 1 V| DA _LCLowpassDT1

Current Design amartComponent Capability
|schematic | |I3u35iu;|nJ Simulate, Yield, Display

CrEr e Filer Assistant Simulation Assistant | Yield Assiskank Display Assistant

Automated SmartComponent Yield Simulation

Yield Frequency Sweep Statistical Components

Start 100 I

Stap 3 laHe v

Step 20 I

Murm, of Paoints |146 | [ YWiew Components ] } Select Yiew

) . ) Components

[ Automatically Set Frequencies ”Set Yield Speu:,l'Gu:uaIs] # Simulations # Iterations P
automatically Display Resulks [ Yield Optimization 250 ” 10 |

[ Simulate ] [ Zreate Template ] [ Help ]
Helps

"Simulake" or "Opimize" automatically optimizes or simulates vield of SmartComponent

"Create Template" creates a simulation template For manual SmartComponent sir

"Zlose Termplate" closes the manual kemplate and updates SmartComponent pat

2. Click View Components. Then click Modify Statistics/Optimization. The network
displays in the schematic along with a dialog box.
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i Statistical Com ponent Values

X

Component Skat Mominal Yalue Skatiskics Opk Morminal Yalue Opimization
1l 2.24 pF none 2.24 pF none —
| = 119 nrnH [ lala ] 1 19 nrH [alala ] !
>
View Skakistical Components ] [Mu:udify StatisticsIOptimizatiDn] [ Close

Select Modify
Statistics /Optimization

To choose components:

1. Choose Enabled from the Statistics Status drop-down menu.

o Modify Component Parameter... rg|

Parameters |L=1 19nH v|
Opkimizakion Statistics
Skatistics Stakus = select Enabled
Tvpe |Gaussian w |
Format |+,|'- Std, Dey % v|
Std, Devy %
10 | |
| | |
| | |
[ Previous ] [ Mexk ] [ Done l

Click Mext untill all the
componens are enabled

2. Click Next to move on to the next component. Repeat this until all 3 components in
the network are enabled, and then click Done.
3. Click Close in the Statistical Component Values dialog box.

To analyze yield sensitivity of the network:

1. In the Yield Assistant tab, click Automatically Set Frequencies.
2. Select by Simulate to start the Yield Assistant and analyze the yield sensitivity to
the selected component values. The results display automatically. The sensitivity

histogram for component C1 is shown here.
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g vari=C1.C

3. Choose File > Close Window from the menu to close the display window.

Deleting the SmartComponent

e To delete the LCLowpassDT SmartComponent, choose Tools > Delete
SmartComponent from the Control window.

© Note
The Delete button on the Control window is different from the Delete button on the ADS schematic
window toolbar.

This completes the step-by-step example.
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Using SmartComponents in Filter
DesignGuide

This DesignGuide provides a large number of passive SmartComponents such as doubly
terminated filters, singly terminated filters and bandpass transformers. SmartComponents
are smart sub-network designs that provide the container for specification parameters and
a schematic representation of the design when place into a design. The tool provides
automated design and analysis for these SmartComponents.

Placing and Editing SmartComponents

SmartComponents can be placed, copied, edited and deleted like other components in the
Advanced Design System. The basics of placement, copying, editing and deleting are
described briefly in this section.

© Note
For help with ADS basic features, refer to the Schematic Capture and Layout (usrguide) documentation.

The components are placed in the schematic by selecting the SmartComponent from the
palette and clicking at the point where you want to place the component in the schematic.

You can display the SmartComponent palette in one of these ways:

e Open the Filter by selecting DesignGuide > Filter.

e Display the SmartComponent palette by selecting the Component Palette - All
button from the Control window toolbar or by selecting View > Component Palette
- All from the Control window menu. Component Palette - All contains all the
SmartComponents.

e Select the Filter DG - All palette from the Component Palette drop-down list box in
the Schematic window toolbar (directly above the palette).

Placing SmartComponents
To place a SmartComponent in the design:

1. In the Schematic window, select the component from the SmartComponent palette.
2. Click within the design window at the location where you want to place the
SmartComponent.

e You can change the orientation of the SmartComponent before placement by
selecting from the Insert > Component > Component Orientation
commands or by selecting Rotate by -90 repeatedly from the schematic
toolbar.

e The place component mode remains active until you choose End Command
from the schematic toolbar.
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Changing Position and Orientation
A SmartComponent is moved by dragging it to any location in the Schematic window.
To change the component's orientation:
1. Select Edit > Advanced Rotate > Rotate Around Reference from the Schematic
window or select Rotate Items from the toolbar.
2. Click the SmartComponent you want to use.

3. Rotate the component. The rotate mode remains active until you select End
Command from the toolbar.

Editing SmartComponents
You can modify the specifications in one of these ways:
e Click the SmartComponent parameters in the schematic window and change them

(see The LCLowpassDT Component.)
e Double-click the SmartComponent to open a dialog box containing all parameters.

DT

DA LCLowpassDT2 —_—
Fp=1 GHz

Fs=2 GHz

Ap=3dBE

As=20 dB

M= ——— Edit SmartComponent
ResponseType=Maximally Flat Parameters here
MinLorC=Minimum Inductance
Fg=50 Chm

RI=50 Chrm
MaxFealizations=25

The LCLowpassDT Component

The SmartComponent design (schematic) can be viewed by pushing into the
SmartComponent's subnetwork. See Examining the SmartComponent Design (ddfilter).
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A SmartComponent subnetwork is empty until the design is generated (see the note in the
section Placing and Editing SmartComponents).

Copying SmartComponents

SmartComponents can be copied within a design, to another design, or to another
Schematic window.

Copying Within a Design
To copy a SmartComponent to the same design:

1. Click the SmartComponent to be copied.
2. Select Edit > Copy and then Edit > Paste from the schematic window.
3. Click where you want the copy placed.

Copying Between Designs or Schematic Windows
To copy a SmartComponent to another design:

Click the SmartComponent to be copied.

Select Edit > Copy from the Schematic window.

Display the design or schematic window you want to copy the SmartComponent to.
Select Edit > Paste to copy the SmartComponent to the design.

Click where you want the component placed.

uAWNE

Copying a SmartComponent as a Unique Design

Initially, all copied SmartComponents refer to the same SmartComponent design. When
the Design Assistant is used to perform a design operation, the Design Assistant
transforms each copied SmartComponent into a unique SmartComponent design. A design
operation is accomplished from the Filter Control Window.

Deleting SmartComponents

SmartComponents can be deleted from a design like other components, but completely
removing a SmartComponent's files requires the actions described here.
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Deleting from Current Design

A SmartComponent can be deleted from a design in one of these ways:
e By selecting the component and pressing the Delete key.

« By selecting Delete from the toolbar.
« By selecting Edit > Delete from the schematic window.

© Note
This procedure does not remove the SmartComponent files from the Workspace directory. To delete
files from the Workspace, see Deleting from Current Workspace.

Deleting from Current Workspace
To delete a SmartComponent and all associated files from your Workspace:

1. In the Schematic window, select the SmartComponent.

2. In the Control window, select Tools > Delete SmartComponent. or on the toolbar,
click Delete . This deletes the SmartComponent from the current design and
removes all of its files from your Workspace. The SmartComponent delete mode
remains active until you select End Command from the schematic toolbar.

Deleting Manually Using File System

You can use your computer's file system to delete a SmartComponent by deleting the
appropriate files in the respective library of a Workspace.

Using SmartComponents as Standalone Components

After SmartComponents are designed and tested, they can be used as standalone
components. The Filter DesignGuide is not needed to use them in new designs unless you
want to modify or analyze them.

Using an Existing SmartComponent Within the Same Workspace
To use an existing SmartComponent within the same Workspace:

1. Open the Component Library window by selecting Insert > Component >
Component Library from the Schematic window or Display Component Library
List on the toolbar.

2. Select the Library name under All Libraries list at the left of the Component Library
window. Available components are listed in the Components list at the right of the
Component Library window. .
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Select the SmartComponent in the Components list.
Place the SmartComponent into your design by clicking in the Schematic window at
the location you wish to place. The insert mode remains active until you click End
Command.

Using an Existing SmartComponent in Any Workspace

A library of predesigned reusable SmartComponents can be created by placing the
reusable SmartComponents in a Workspace. This Workspace can be included in any other
Workplace and its SmartComponents can be accessed using the Component Library.

To use an existing SmartComponent in any Workspace:

1.
2.

3.

Open the Workspace where the SmartComponent needs to be inserted.

Select the Workspace that contains the SmartComponent from list in the Include &
Remove window.

Click Include to include the Workspace in the hierarchy and click OK.

Open the Component Library window by selecting Insert > Component >
Component Library from the Schematic window or Display Component Library
List from the toolbar.

Select the included Workspace name under All > Sub-networks in the Libraries list
at the left of the Component Library window. Available components are listed in the
Components list at the right of the Component Library window.

Select the SmartComponent in the Components list.

Place the SmartComponent into your design by clicking in the Schematic window at
the location where you wish to place the component. The insert mode remains active
until you click End Command.
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Using Automated Assistants in Filter
DesignGuide

This section describes the Automated Assistants available in this DesignGuide.

Filter Assistant is used to generate and update the design contained within a
SmartComponent's schematic design for filter networks.

Simulation Assistant is used to automatically perform a simulation of a
SmartComponent.

Yield Assistant is used to automatically perform a simulation of a SmartComponent's
network sensitivity.

Display Assistant is used to automatically display the analysis results generated using
the Simulation Assistant.

Transformation Assistant is provides an interactive environment for transforming
lumped elements to transmission lines within a designed SmartComponent.

Filter Assistant

Simulation Assistant
’7 |— Yield Assistant

o B 0 X Y

L Transformation Assistant
Display Assistant

Filter Assistant

The Filter Assistant is used to generate and update the design contained within a single
SmartComponent from the given specifications. The Filter Assistant is accessed using the
Filter DesignGuide Control window. From the Control window, full design control is enabled
from the Filter Assistant tab. Component design operations can also be accomplished
using the Control window menu and toolbar. Any parameter change made from the Filter
Assistant tab is reflected on the SmartComponent in the schematic.
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Overyie Filter Assistant Simulation Assiskant Yield Assistant Display Assistank

Ap (dE
Impedanices Response Type 3p|: )
Source Load Manimally Flak v
50 50 A= (dB)
First Elerment <0
Parallel w 2 % | dBfsquare

Crder (M)
4
Realizations
[] wiew al
Design Information M 2
Order: 1
4
Minimum Insertion Loss: .
0.0000 Fp Fs Lnits
1 2 GHz »
Design ] [ Fedraw ] [ Help ]

To view a SmartComponent, select the SmartComponent from the SmartComponent
drop-down list box in the upper right corner of the Control window. The SmartComponent
parameters are shown inside the Filter Assistant tab.

Impedances

e Source - Source termination impedance(Rg), in Ohms. This value must be a real
number greater than zero.

e Load - Load termination impedance(RI), in Ohms. This value must be a real number
greater than zero.

« First Component - Either parallel or series. Refers to the first component in the
network topology after designing. Parallel designs for minimal inductor values in the
network. Series designs for minimal capacitor values in the network.

Order

The filter order is automatically calculated depending upon the parameters specified for all
the response types except Bessel-Thomson and Gaussian. For these two responses a filter
order must be input manually using the Order (N) text box.

Design Information
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Design Information is not editable, but rather shows information about the filter.

e Order - Is the filter order.
e Minimum Insertion Loss - Shows the minimum insertion loss due to unequal
terminations. The insertion loss is zero if terminations are matched.

Response Type

Six filter response types can be used for designing: Maximally Flat (Butterworth),
Chebyshev, Elliptical, Inverse-Chebyshev, Bessel-Thomson, and Gaussian. A plot of the
filter response is show below the Response Type drop-down list box. Pressing the
Redraw button automatically scales and redraws the response plot.

Frequency

Frequency settings can be changed by either moving the vertical frequency slide bars on
the response plot or by changing the values in the frequency text boxes. The frequency
text box captions dynamically change depending on the SmartComponent being used. For
any lowpass or highpass network:

e Fp - Passband corner frequency
e Fs - Stopband frequency edge
e Units - Used for both frequencies

For any bandpass of bandstop network:

Fp1 - Lower passband corner frequency
Fp2 - Upper passband corner frequency
Fs1 - Lower stopband frequency edge
Fs2 - Upper stopband frequency edge
Units - Used for all frequencies

Attenuation

Attenuation settings can be changed by either moving the horizontal attenuation slide bars
on the response plot or by changing the values in the attenuation text boxes.

« Ap - Passband attenuation, in dB
e As - Stopband attenuation, in dB

Zooming in/out of the response plot is possible using the dB/square spin-box.

Realizations
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These parameters tell the Filter DesignGuide how many networks to show after designing.
If View All is not checked only one network is synthesized. If View All is checked the
number of shown networks can be specified in the Max # text box.

Design
The design is accomplished using one of the these methods.

« Click Design on the Filter Assistant tab. The design progress is indicated on the tab

page.
« Click Design on the Control window toolbar.
e Choose Tools > Auto-Design from the Control window menu.

If multiple realizations for the filter network were found, a dialog box appears.

Filter DesignGuide:1 ¥ x|

Component List

i =1 of 3networks
=

Input Port _|
PLC PG L=1.18817 nH C=106593 pF

SLC SE L=566353rnH C=223626 pF
PLC PG L=1.18817 nH C=10.6593 pF
COutput Port

i of
Done |

All networks can be viewed using the Component List spin box. Each network can be
viewed in two places:

e Dialog Box - Shows a text based description of the current network.

e Schematic Window - Shows the actually drawing of the current network.
Choosing the Done button causes the dialog box to close. The last viewed filter
network becomes the subnetwork of the designed SmartComponent.

Simulation Assistant

The Simulation Assistant is used to analyze the design contained within a
SmartComponent. The Simulation Assistant creates a simulation circuit around the
SmartComponent, then automatically performs the appropriate simulation. If set, the tool
displays the simulation results automatically.
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The Simulation Assistant is accessed using the Filter DesignGuide Control window, where
full simulation control is enabled from the Simulation Assistant tab. Also, basic simulation
can be accomplished using the Control window menu and toolbar.

Overyie Filker Assistant Simulation Assistant Yield Assistant Display Assistant
Automated SmarkComponent Simulation

Simulation Frequency Sweep

Skart 100 MHz  + |[¥] Automatically Display Results
Stop 3 GHz w [ Automatically Set Frequencies
Step 20 MHz W

Mum, of Points | 146

Simulate ] [ Create Template ] [ Help
Helps
"Sirnulate" automatically simulates selected SmartComponent
"Create Template" creates a simulation template For manual SmartComponent sir

For all simulation operations, the selected SmartComponent is designed if necessary, a
simulation schematic is created, the simulation is performed, and the results are
displayed. The simulation frequency sweep must be specified on the Simulation Assistant
tab in the Control window as described in detail in section Simulation Frequency Sweep.

Simulation Frequency Sweep

The simulation frequency sweep is specified on the Filter DesignGuide Control window.
While performing the simulation from the Control window, select the Simulation Assistant
tab and specify the sweep by entering the start frequency, stop frequency, and either
frequency step size or number of points. The values entered are stored in the selected
SmartComponent (as displayed in the SmartComponent drop-down list box) and is
recalled each time this SmartComponent is selected.

Automatically Display Results

If the Automatically Display Results box on the Simulation Assistant tab is selected,
the simulation results are automatically displayed upon completion of the analysis.

Starting the Simulation
The simulation can accomplished using one of the these methods.
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e Choose the Simulate button on the Simulation Assistant tab.
e Choose the Simulate button on the Control window toolbar.
e Choose Tools > Auto-Simulate from the Control window menu.

Simulation Templates

In some cases, you can simulate the SmartComponent manually. To generate a simulation
schematic around the selected SmartComponent, press the Create Template button on
the Control window Simulation Assistant tab. You can examine or modify the simulation
schematic, then manually start the simulation by selecting Simulate > Simulate from
the Schematic window.

Yield Assistant

The Yield Assistant is used to analyze the design sensitivities contained within a
SmartComponent. The Yield Assistant creates a yield analysis circuit containing the
SmartComponent, then performs a simulation. By sweeping the component values for a
selected set of components in the network, this analysis generates a probability density
function of the performance given statistical variations of the component values. The
probability that the performance remains within the specified bounds is the yield of the
network.

The Yield Assistant is accessed using the Filter DesignGuide Control window, where full
control is enabled from the Yield Assistant tab. Also, basic yield analysis can be
accomplished using the Control window menu and toolbar.

Overyie Filker Assistant Simulation Assiskant Yield Assiskant Display Assistank

Automated SmarkComponent Yield Simulation

Yield Frequency Sweep Statistical Components

Start 100 MHz

Stop 3 GHz

Step 20 MHz W

Mum, of Points | 146 [ View Compaonents ]
[ Automatically Set Frequencies ][Set Yield Spec,l'Gu:uaIs] # Simulations # Iterations
automatically Display Resules [ ¥ield Optimization 2t 10

[ Simulate ] [ Create Template ] [ Help ]
Helps

"Simulate” or "Optimize" automatically optimizes or simulates vield of SmartComponent
"Create Termplate" creates a simulation template For manual SmartComponent: sir
"Close Template" closes the manual template and updates SmarkComponent pat
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The selected SmartComponent must be designed before yield analysis can be performed.
The analysis proceeds by statistically sweeping the value of each selected component and
analyzing the impact of this component value variation on the frequency response of the
network.

Simulation Frequency Sweep

The simulation frequency sweep is specified on the Yield Assistant tab of the Filter
DesignGuide Control window. From this tab, specify the sweep by entering the start
frequency, stop frequency, and either frequency step size or number of points. The values
entered are stored in the selected SmartComponent (as displayed in the SmartComponent
drop-down list box) and are recalled each time this SmartComponent is selected.

Statistical Components

The Statistical Components list-box displays all components that are statistically varied
during simulation.

Clicking View Components opens a dialog box that shows the yield status of the
components in the network.

Clicking Modify Statistics/Optimization opens the Modify Component Parameters
dialog to simplify the process of selecting components. The filter network is displayed in
the schematic with the currently-selected component highlighted.

x
Farameters _10.EE

Optimization ~ Statistics ]

Statistics Status |Elear LJ

| -

| -

| | [~

| | [~

| | -

Presvious I M et I [lane |

To sweep this component value statistically during the analysis, select Enabled in the
Statistics Status box. Then specify the parameters of the statistical sweep.
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After you have specified all parameters for a component, clicking Next proceeds to the
next component in the network. You can select a maximum of 4 components at one time.
After you have finished specification, click Done .

Click View Statistical Components to view a summary of the statistical parameters for
each selected component. Click Modify Statistics/Optimization to open the Modify
Component Parameters dialog from this summary dialog to facilitate editing of the
statistical sweep parameters.

The # Simulations parameter specifies the number of Monte Carlo simulations that are
used to estimate the statistical behavior of the network. Increasing the number of
simulations increases the statistical sample size and therefore provides a better estimate
of the performance at the expense of increased computational time.

Yield Optimization

The network component values can also be optimized so that the performance is less
sensitive to component value variations. This can be accomplished by selecting the Yield
Optimization check box. The simulation uses the ADS engine to optimize the selected
component values.

Specifying an appropriate set of Yield/Optimization Goals is a critical step in ensuring this
optimization yields acceptable results. The # Iterations parameter available for Yield
Optimization specifies the maximum number of optimization iterations that the simulation
performs to try to find the appropriate network component values.

Yield/Optimization Goals

Yield and Yield Optimization simulations require that a set of performance (yield) goals be
specified for the network. The yield is defined as the probability that the network
frequency response satisfies these performance specifications given the statistical
properties of the individual components.

Yield simulations use these goals to determine the percentage of networks that satisfies
the specifications given tolerances of the components. Yield Optimization simulations use
the goals in determining suitable component values that maximize the yield.

Each component has a default set of goals depending on the type of response (lowpass,
bandpass, etc.). You can modify these goals, including adding or deleting goals, by
clicking Set Yield Spec/Goals on the Yield Assistant tab to display the dialog.
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i Set Yield/Optimization Goals

Active
21 w||le=  w||z0 dE |at w1 GHz % ko 1.1 zHz
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>
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add Goal Delete All Goals Default

Each goal specifies the insertion loss performance of the network in dB and can represent
a specification that the value stay above or below the stated level. The specification can
be at a single point, or over a given frequency band.

Add Goal - Add new goals.

Del - Delete individual goals.

Delete All Goals - Delete all goals.

Default - Resets goals to default values.

Active - A goal is used in the analysis only if the Active box at the left of the goal
line is checked.

Automatically Display Results

If the Automatically Display Results box on the Control window Yield Assistant tab is
selected, the simulation results are displayed automatically after completion of the
analysis.

Starting the Simulation
The yield analysis can accomplished using one of these methods.

e Click the Simulate button on the Yield Assistant tab.
e Click the Simulate Yield button on the Control window toolbar.
e Choose Tools > Auto-Simulate Yield from the Control window menu.

Yield Results

For each component (up to a maximum of 4) chosen for yield analysis, a yield sensitivity
histogram is displayed. The yield definition can be changed on the first page of the display
by setting passband frequencies Fp_1 and Fp_2 as well as the maximum insertion loss at
these frequencies, and stopband frequencies Fs_1 and Fs_2 as well as the minimum

insertion loss at these frequencies. Other pages in the display show the overall statistics of
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the yield as well as the frequency response for each of the Monte Carlo simulations.

Yield Templates

In some cases, you can simulate the SmartComponent manually. To generate a simulation
schematic around the selected SmartComponent, click Create Template on the Control
window Yield Assistant tab. You can examine or modify the simulation schematic, then
manually start the simulation by selecting Simulate > Simulate from the Schematic
window. When you are finished, clicking Close Template on the Yield Assistant tab
returns you to the original design. You can close the simulation schematic manually using
File > Close Design from the Schematic window menu.

Display Assistant

The Display Assistant is used to easily and quickly display the performance of a
SmartComponent. The display templates are preconfigured display files that provide a
comprehensive look at the performance of the component. You can create your own
displays or modify the included display templates using the built in features of Advanced
Design System, but in most situations, the included display templates provide all the
information you need.

The Display Assistant is accessed using the Filter DesignGuide Control window, where full
display control is enabled from the Display Assistant tab. Basic display selection can also
be accomplished using the Control window menu and toolbar.

Crveryig Filker Assistant Simulation Assiskant Yield Assistant Display Assistank

Automated Display of SmartComponent Simulation Resulks

Associated Data Display
Wa_LCYieldDT
Associated Data Set

4

Available Templates

Dioubly Terminated Yield Display ~
Doubly Terminated Lowpass Filker Display

Singly Terminated Yield Display

Singly Terminated Lowpass Filker Display

Dioubly Terminated Highpass Filker Display

Sing_l*;._f Terminated Highpass Filtn_ar Displa}f w
Display ] [ Open Display Template ] [ Help
Helps
"Display" opens display for selected SmartComponent using Associated
"Open Display Template" opens display selectked From the list of Available Templates
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Display Template Features
The display templates opened by the Display Assistant have common features that are

discussed here. For features unique to the display templates of some SmartComponents,
refer to the section SmartComponent Reference (ddfilter).

Basic Layout

Basic Layout of Display Template shows the basic layout of the display templates. Area
one of the display template contains a graph of the most important parameters of the
SmartComponent. Area two contains several graphs that give a comprehensive look at the
component's performance. Area three contains a table listing the basic specifications and
performance of the component.

Basic Layout of Display Template

Typical Area One Graph

Typical Graphs from Area One shows a typical graph from area one of a display template.
The frequency range of the graph is determined by the Simulation Assistant. As you
change the frequency range in the Simulation Assistant, this graph updates appropriately.
The markers A and B are used to define the frequency range of the graphs in area two.
This feature is used to zero in on the region of interest and obtain a comprehensive look
at the component's performance. The marker M1 can be moved by dragging the marker
with the mouse. The performance at the frequency given by M1 is shown in the table in
area three.
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Typical Graphs from Area One

Typical Area Two Graphs

Typical graphs from area 2 of a display template are shown in Typical Graphs from Area
Two. These graphs provide a quick, comprehensive look at the component's performance.
Their frequency range is determined by the location of the "A" and "B" markers found in
the main graph. Any markers such as M2 shown here can be moved by dragging them
with the mouse. Performance criteria at the marker frequency is displayed in the table in

area three.

Magnified A->B Magnified A->B

Maanified A-=8

L I A J e I. Il
531 (0 Coupling)
1

511 (RLoss)
|
S21 (1 Coupling)

r[l r|.1 1 1]1]1]1‘! ':I

Typical Graphs from Area Two

Typical Area Three Templates

A typical table from area three of a display template is shown in Typical Table from Area
Three. The white rows show the specifications and important performance criteria for the
component. The gray rows give the performance criteria at the user defined marker
frequencies. The box below the table provides explanatory information for the table.

35



Advanced Design System 2011.01 - Filter DesignGuide

F S11 s21 S31 5441 PhaseD

Desired Center Frequenacy .00 -10.72 -4.604 -2.91 -12.15 24.94
Actual Center Frequency 5.80 -30.15 -2.64 -39 -30.81 Q0,23
Change/orst A->B 5.00 -4.20 -8.16 -5.941 7.22 70.77]
Marer M1 500 -1072 464 2.91 4215 84 04
Marker M2 BO0D[ -2247 254 365 [ 2225 sg.ﬁq

F: Frequency (GHzZ) Note: Change/iWorst A->B provides performance

1: Input Port overthe range from maker Ato B, The change

2: In-phase (I) Port of F and PhaseD are given, and the worst case

3: Quadrature (Q) Port S-parameter values are given.

4: lsolated Port

C: Desired Coupling

PhaseD: |-Q Phase Difference

Typical Table from Area Three

Display Assistant Operation

Before using the Display Assistant, a valid dataset from a simulation of the selected
SmartComponent must exist in the current Workspace. This simulation can be
conveniently accomplished using the Simulation Assistant. Refer to the Simulation
Assistant section for details on this step.

Opening a Display

To display results from a SmartComponent simulation using the Control window, select
the SmartComponent from the SmartComponent drop-down list box in the upper right
corner of the Control window. The display is launched using one of the these methods.

« Click the Display button on the Display Assistant tab.
e Click the Display button on the Control window toolbar.
e Choose Tools > Auto-Display from the Control window menu.

If no valid dataset exists for the selected SmartComponent, the Display button on the

Display Assistant tab is insensitive. If the toolbar or menu are used to try to display the
results, a message appears, indicating that no dataset exists.
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Display Templates

In some cases, you can use one of the display templates provided with the DesignGuide
for other applications. To gain access to one of these templates, select the template from
the Available Templates field and click Open Display Template on the Control window
Display Assistant tab. Insert a dataset of your choice using the dataset pull-down list box
in the upper left corner of the display. If you find that some parameters in the display
template are not defined in the selected dataset, you can make appropriate modifications
to the display. You can save these changes by using the commands in the display File
menu.

Transformation Assistant

After a Filter DesignGuide SmartComponent has been designed, the lumped inductors and
capacitors can be transformed into equivalent distributed element counterparts using the
Transformation Assistant. This feature enables you to quickly and easily transform an ideal
filter topology to a form that is realizable for high-frequency systems.

The Transformation Assistant is opened from the Filter DesignGuide Control window,
either by selecting Tools > Distributed Element Transformations from the Control
window menu or from the Toolbar.

When the Transformation Assistant is opened, the SmartComponent subnetwork appears
in the schematic window and a dialog box is opened. The transformations are then
accomplished using the controls on the dialog.

xq
Transfomatinns Ledt-chck component type bo hrandfiom
¢ | LC bo TLine
| TLine la TLine [Kusoda) e
| L, Tiline bo Miciostn
Component Selection
_l_
[« =] I
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Helps
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Selecting a Transformation Type
The type of transformation to be applied is selected from three options:

e LC to TLine - Transforms lumped inductors and capacitors to ideal transmission line
elements. Eight different inductor/capacitor combinations can be transformed to
different series lines, series stubs, or shunt stubs.

e TLine to TLine (Kuroda) - Apply Kuroda's identities in order to transform series short
circuited stubs to shunt stubs that are realizable in microstrip and other printed
transmission line technologies.

e LC, TLine to Microstrip - Transforms lumped inductors and capacitors as well as ideal
transmission line structures to microstrip equivalent components. Application of this
transformation requires a valid license for the Passive Circuit DesignGuide.

After a transform has been selected, the graphical area displays the components that can
be transformed using the current selection. Black components represent elements
included in the original circuit available for transformation, while gray components
represent elements not included in the original circuit.

From this graphical area, use the left mouse button to select one of the available
component types. The graphical area changes to reveal the different distributed element
equivalents available for substitution. Transformations Available for a Series Inductor
Circuit shows the transformations available when a series inductor circuit has been

selected.
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Transformations Available for a Series Inductor Circuit

From this point, the type of equivalent network can be selected using the left mouse
button from the available structures at the right of the graphics area. A box highlights the
currently selected structure. Text at the bottom of the window changes as different
selections are made, providing help for the particular transform selected.

Component Selection

After the type of circuit component to be transformed is selected, the actual circuit
elements to apply the transform to can be selected using the Component Selection tools.
As the left and right arrows within this area are pushed, valid components within the
original circuit are highlighted, and their instance names (i.e. L1, C4) appears in the text
box on the Transformation Assistant dialog. The three buttons are used to select the
specific components that should be subjected to the current transformation:

e Add - Add the currently selected component(s) to the transformation list.

e Add All - Add all circuit components of the appropriate type to the transformation list.

e Cut - Remove the currently selected (highlighted) item in the transformation list from
the list.

Transformation Buttons

The buttons across the bottom of the dialog box are used to accomplish the
transformation on the selected components.

e Transform - Apply the selected transform to the component in the transformation list.

e Undo - Undo the last performed transform. This button can be used repeatedly to
undo all previous transformations.

e OK - Accept the current transformed circuit and close the dialog box. After the
transformed circuit has been accepted, transformations cannot be undone.

e Cancel - Close the dialog box and revert to the original, untransformed circuit.

Changing Component Type

After all transformations have been made on a specific component type (such as series
inductor), performing a left mouse click the red return arrow in the upper left hand corner
of the graphic area (or performing a right mouse click anywhere on the graphic area) can
be used to return to the main component selection page. Another component type can
then be selected, and the transformation steps can be repeated for this new selection.
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Transmission Line Types

Five basic transmission line elements can be produced using the Transformation Assistant.
These are identified as:

Series Transmission Line

Series Short Circuit Stub

Series Open Circuit Stub

Parallel Short Circuit Stub

Parallel Short Circuit Stub

=fol b

Additional Transformation Functions

Unit Element

For certain transformations, either the electrical length or characteristic impedance of the
resulting transmission line must be specified by the user. If the Unit Element box is
checked, the resulting transmission line has an electrical length of 45 degrees and the
characteristic impedance is computed appropriately. If the Unit Element box is unchecked,
then the Characteristic Impedance (Z0) box becomes active and the computation uses this
characteristic impedance to compute the appropriate length.

Characteristic Impedance

The Characteristic Impedance (Z0) box is used to specify the transmission line
characteristic impedance for certain transformations. In cases where either the electrical
length or the characteristic impedance can be specified, this box works in conjunction with
the Unit Element box as discussed above. In certain other cases, this Characteristic
Impedance (Z0) box is used alone. For example, when adding lines to the front or end of
a network as part of Kuroda's identities, the characteristic impedance of the
transformation can be specified using this box.

40



Advanced Design System 2011.01 - Filter DesignGuide

Add Transmission Lines

As part of the TLine to TLine transformation, unit element (45 degree electrical length)
transmission lines can be added to the front or end of the network. The characteristic
impedance of these lines is specified using the Characteristic Impedance (Z0) box. Such
lines can be added as needed during the transformation process.

© Note
Addition of these lines changes the phase response and, if the characteristic impedance is not equal to the
network terminal impedance, the magnitude response of the network.

Microstrip Substrate

When performing LC, TLine to MLine transformations, the microstrip substrate thickness
(h) and relative permittivity (Er) must be specified. All microstrip elements within a design
must share the same substrate parameters. The substrate parameters used in the final
design are the values that appear in the boxes after the final transformation step.

TLine to TLine Transforms (Kuroda Identities)

The TLine to TLine transforms are typically used to transform series short-circuited stubs
to parallel open circuited stubs in preparation for implementation in planar transmission
line technologies. However, these operations only work on Unit Element lines with
electrical lengths of 45 degrees. Therefore, when performing lumped to ideal distributed
transformations, you must perform substitutions that conform to this Unit Element
specification. Preferred stubs (highlighted in blue on the graphical area) as well as series
transmission lines (transformed with the Unit Element box checked) can be transformed in
this way. When adding transmission line elements before or after the network, the
electrical length is 45 degrees and only the characteristic impedance must be specified.

Microstrip Transforms

© Note
This set of transforms is only available if a valid license for the Passive Circuit DesignGuide exists.

The LC, TLine to MLine transformations form a somewhat unique class of operations. This
set of transformations takes lumped inductor/capacitor combinations as well as ideal
series transmission lines and shunt transmission line stubs (obtained from the LC to TLine
transformations), and converts them to microstrip. Note that series stubs cannot be used
in this transformation since series stubs cannot be realized in microstrip.

In addition to the standard transmission line topologies, certain lumped elements can be
replaced with SmartComponents from the Passive Circuit DesignGuide. The available
SmartComponents are:
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_Izq_ Interdigital Capacitor (can be in series or parallel)

Series Microstrip Thin Film Capacitor
Rectangular Spiral Inductor {can be in series or parallel)

Spiral Inductor (can be in series or parallel)

Parallel Radial Stub

Parallel Butterfly Radial Stub

R > ¢ B |

When making such substitutions, the design capabilities of the Passive Circuit DesignGuide
are used to realize the topologies. In this case, however, the design procedure is
approximate, and some tuning of the elements can be required before the substituted
device offers the correct performance. In such cases, after completion of the
transformation, push into the SmartComponent on the schematic window and open the
Passive Circuit DesignGuide Control window. The Simulation and Optimization Assistants
in the Passive Circuit DesignGuide SmartComponent can then be used to quickly and
efficiently tune the performance of each individual element.
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SmartComponent Reference for Filter
DesignGuide

This section provides detailed information for all filter SmartComponents.

SmartComponent List

LCLowpassDT (Doubly Terminated Lowpass Filter) (ddfilter)
LCHighpassDT (Doubly Terminated Highpass Filter) (ddfilter)
LCBandpassDT (Doubly Terminated Bandpass Filter) (ddfilter)
LCBandstopDT (Doubly Terminated Bandstop Filter) (ddfilter)
LCLowpassST (Singly Terminated Lowpass Filter) (dgfilter)
LCHighpassST (Singly Terminated Highpass Filter) (ddfilter)
LCBandpassST (Singly Terminated Bandpass Filter) (ddfilter)

LCBandstopST (Singly Terminated Bandstop Filter) (ddfilter)

LCBandpassDT (Doubly Terminated Bandpass Filter)

Symbol

DT

Parameters
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Name
Fs1

Fpl

Fp2

Fs2

Ap

As

N
ResponseType
MinLorC
Rg

RI

Advanced Design System 2011.01 - Filter DesignGuide

Description

Lower stopband frequency

Lower passband corner frequency
Upper passband corner frequency
Upper stopband frequency
Passband attenuation

Stopband attenuation

Order of filter, unitless

Type of filter response

Minimum inductance or capacitance
Source impedance

Load impedance

Unit Default

GHz |.5

GHz |1

GHz |2

GHz |2.5

dB |3

dB |20

None |0

None Maximally Flat
None |Minimum Inductance
Ohm |50

Ohm |50

MaxRealizations |Maximum number of realizations during synthesis None |25

Notes

1. A doubly terminated bandpass filter provides a bandpass frequency response
between the input (pin 1) and output (pin 2) ports. This component can have any
real, non-zero impedance at either the source or load terminations.

2. The type of frequency response (that is, Chebyshev, Elliptical, etc.) depends on the
parameter ResponseType. The transition bands of the frequency response depend on
the filter order.

3. The filter order is either set manually or is calculated by the passband and stopband
frequencies and attenuations.

Example

An elliptical bandpass filter (Elliptical Bandpass Filter) was designed for 3dB attenuation
between 1 GHz and

2 GHz and 20 dB attenuation below .5 GHz and above 2.5 GHz with matched 50 ohm
loads. This resulted in a filter order of N=4.

Figure: Elliptical Bandpass Filter
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LCBandpassST (Singly Terminated Bandpass Filter)

Symbol

2

ST

Parameters
Name Description Unit Default
Fs1 Lower stopband frequency GHz |.5
Fpl Lower passband corner frequency GHz |1
Fp2 Upper passband corner frequency GHz 2
Fs2 Upper stopband frequency GHz 2.5
Ap Passband attenuation dB |3
As Stopband attenuation dB |20
N Order of filter None |0
ResponseType |Type of filter response None Maximally Flat
Termination Open or short load termination None Short Termination
Rg Source impedance Ohm |50

MaxRealizations Maximum number of realizations during synthesis None |25

Notes
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1. A singly terminated bandpass filter provides a bandpass frequency response between
the input (pin 1) and output (pin 2) ports. This component has a real, hon-zero
source termination and either an open or short at the load termination.

2. The type of frequency response (that is, Chebyshev, Elliptical, etc.) depends on the
parameter ResponseType. The transition bands of the frequency response depend on
the filter order.

3. The filter order is either set manually or is calculated by the passband and stopband
frequencies and attenuations.

Example

An elliptical bandpass filter (Elliptical Bandpass Filter) was designed for 3 dB attenuation
between 1 GHz and 2 GHz and 20 dB attenuation below .5 GHz and above 2.5 GHz with a
50 ohm source and shorted load. This resulted in a filter order of N=4.

Figure: Elliptical Bandpass Filter
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LCBandstopDT (Doubly Terminated Bandstop Filter)

Symbol

DT
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Parameters

Name Description Unit Default

Fpl Lower passband corner frequency GHz |.5

Fs1 Lower stopband frequency GHz |1

Fs2 Upper stopband frequency GHz |2

Fp2 Upper passband corner frequency GHz |2.5

Ap Passband attenuation B 3

As Stopband attenuation dB 20

N Order of filter None |0
ResponseType |Type of filter response None Maximally Flat
MinLorC Minimum inductance or capacitance None |Minimum Inductance
Rg Source impedance Ohm |50

RI Load impedance Ohm 50

MaxRealizations |Maximum number of realizations during synthesis None |25

Notes

1. A doubly terminated bandstop filter provides a bandstop frequency response between
the input (pin 1) and output (pin 2) ports. This component can have any real, non-
zero impedance at either the source or load terminations.

2. The type of frequency response (that is, Chebyshev, Elliptical, etc.) depends on the
parameter ResponseType. The transition bands of the frequency response depend on
the filter order.

3. The filter order is either set manually or is calculated by the passband and stopband
frequencies and attenuations.

Example

An Inverse-Chebyshev bandstop filter (Inverse-Chebyshev Bandstop Filter) was designed
for 20 dB attenuation between 1 GHz and 2 GHz and 3 dB attenuation below .5 GHz and
above 2.5 GHz with matched 50 ohm loads. This resulted in a filter order of N=4.

Figure: Inverse-Chebyshev Bandstop Filter
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LCBandstopST (Singly Terminated Bandstop Filter)

Symbol

ST
Parameters
Name Description Unit Default
Fpl Lower passband corner frequency GHz |.5
Fs1 Lower stopband frequency GHz |1
Fs2 Upper stopband frequency GHz |2
Fp2 Upper passband corner frequency GHz 2.5
Ap Passband attenuation dB |3
As Stopband attenuation dB |20
N Order of filter None |0
ResponseType |Type of filter response None Maximally Flat
Termination Open or short load termination None |Short Termination
Rg Source impedance Ohm |50

MaxRealizations |Maximum number of realizations during synthesis None |25
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Notes

1. A singly terminated bandstop filter provides a bandstop frequency response between
the input (pin 1) and output (pin 2) ports. This component has a real, non-zero
source termination and either an open or short at the load termination.

2. The type of frequency response (that is, Chebyshev, Elliptical, etc.) depends on the
parameter ResponseType. The transition bands of the frequency response depend on
the filter order.

3. The filter order is either set manually or is calculated by the passband and stopband
frequencies and attenuations.

Example

A maximally flat bandstop filter (Maximally Flat Bandstop Filter) was designed for 20 dB
attenuation between 1 GHz and 2 GHz and 3 dB attenuation below .5 GHz and above 2.5
GHz with a 50 ohm source and an open load. This resulted in a filter order of N=7.

Figure: Maximally Flat Bandstop Filter
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LCHighpassDT (Doubly Terminated Highpass Filter)

Symbol

DT
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Parameters

Name Description

Fs Stopband frequency

Fp Passband corner frequency

Ap Passband attenuation

As Stopband attenuation

N Order of filter

ResponseType |Type of filter response

MinLorC Minimum inductance or capacitance
Rg Source impedance

RI

Load impedance

Unit
GHz
GHz
dB
dB
None
None
None
Ohm
Ohm

MaxRealizations |Maximum number of realizations during synthesis |None

Notes

Default

1

2

3

20

0

Maximally Flat
Minimum Inductance
50

50

25

1. A doubly terminated highpass filter provides a highpass frequency response between
the input (pin 1) and output (pin 2) ports. This component can have any real, non-
zero impedance at either the source or load terminations.

The type of frequency response (i.e. Chebyshev, Elliptical, etc.) depends on the
parameter ResponseType. The transition bands of the frequency response depend on

2.

3.

the filter order.

The filter order is either set manually or is calculated by the passband and stopband

frequencies and attenuations.

Example

A chebyshev highpass filter (Chebyshev Highpass Filter) was designed for 20dB
attenuation at 1 GHz and 3 dB attenuation at 2 GHz with matched 50 ohm terminations.
This resulted in a filter order of N=3.

Figure: Chebyshev Highpass Filter
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LCHighpassST (Singly Terminated Highpass Filter)

Symbol

R PRy S

ST

Parameters
Name Description Unit Default
Fs Stopband frequency GHz |1
Fp Passband corner frequency GHz 2
Ap Passband attenuation B 3
As Stopband attenuation dB 20
N Order of filter None |0
ResponseType |Type of filter response None Maximally Flat
Termination Open or short load termination None Short Termination
Rg Source impedance Ohm |50

MaxRealizations |Maximum number of realizations during synthesis None |25

Notes

1. A singly terminated highpass filter provides a highpass frequency response between
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the input (pin 1) and output (pin 2) ports. This component has a real, nhon-zero
source termination and either an open or short at the load termination.
2. The type of frequency response (that is, Chebyshev, Elliptical, etc.) depends on the
parameter ResponseType. The transition bands of the frequency response depend on
the filter order.

3. The filter order is either set manually or is calculated by the passband and stopband
frequencies and attenuations.

Example

A chebyshev highpass filter (Chebyshev Highpass Filter) was designed for 20 dB
attenuation at 1 GHz and 3 dB attenuation at 2 GHz with matched 50 ohm terminations.
This resulted in a filter order of N=4.

Figure: Chebyshev Highpass Filter
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LCLowpassDT (Doubly Terminated Lowpass Filter)

Symbol

DT
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Parameters

Name Description

Fp Passband corner frequency

Fs Stopband edge frequency

Ap Passband attenuation

As Stopband attenuation

N Order of filter

ResponseType |Type of filter response

MinLorC Minimum inductance or capacitance
Rg Source impedance

RI

Load impedance

Unit
GHz
GHz
dB
dB
None
None
None
Ohm
Ohm

MaxRealizations Maximum number of realizations during synthesis None

Notes

Default

1

2

3

20

0

Maximally Flat
Mininum Inductance
50

50

25

1. A doubly terminated lowpass filter provides a lowpass frequency response between
the input (pin 1) and output (pin 2) ports. This component can have any real, non-
zero impedance at either the source or load terminations.

The type of frequency response (that is, Chebyshev, Elliptical, etc.) depends on the
parameter ResponseType. The transition bands of the frequency response depend on

2.

3.

the filter order.

The filter order is either set manually or is calculated by the passband and stopband

frequencies and attenuations.

Example

A maximally flat lowpass filter (Maximally Flat Lowpass Filter) was designed for 3dB
attenuation at 1 GHz and 20dB attenuation at 2 GHz with matched 50 ohm terminations.
This resulted in a filter order of N=4.

Figure: Maximally Flat Lowpass Filter
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LCLowpassST (Singly Terminated Lowpass Filter)

Symbol

ST

Parameters

Name Description Unit Default

Fp Passband corner frequency GHz |1

Fs Stopband frequency GHz |2

Ap Passband attenuation dB |3

As Stopband attenuation dB 20

N Order of filter None |0

ResponseType |Type of filter response None Maximally Flat
Termination Open or short load termination None Short Termination
Rg Source impedance Ohm |50

MaxRealizations |Maximum number of realizations during synthesis None |25

Notes

1. A singly terminated lowpass filter provides a lowpass frequency response between
the input (pin 1) and output (pin 2) ports. This component has a real, non-zero
source termination and either an open or short at the load termination.
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2. The type of frequency response (that is, Chebyshev, Elliptical, etc.) depends on the
parameter ResponseType. The transition bands of the frequency response depend on
the filter order.
3. The filter order is either set manually or is calculated by the passband and stopband
frequencies and attenuations.

Example

A maximally flat lowpass filter (Maximally Flat Lowpass Filter) was designed for 3 dB
attenuation at 1 GHz and 20 dB attenuation at 2 GHz with matched 50 ohm terminations.
This resulted in a filter order of N=4.

Figure: Maximally Flat Lowpass Filter
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